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Teamwork Server Client User's Guide 

The software and documentation are furnished under the Teamwork Server license agreement and may be used only in 
accordance with the terms of the agreement. 

Copyright Information  
Copyright c 1999-2007 by Visual Paradigm. All rights reserved.  

The material made available by Visual Paradigm in this document is protected under the laws and various international laws 
and treaties. No portion of this document or the material contained on it may be reproduced in any form or by any means 
without prior written permission from Visual Paradigm. 

Every effort has been made to ensure the accuracy of this document. However, Visual Paradigm makes no warranties with 
respect to this documentation and disclaims any implied warranties of merchantability and fitness for a particular purpose. The 
information in this document is subject to change without notice. 

All examples with names, company names, or companies that appear in this document are imaginary and do not refer to, or 
portray, in name or substance, any actual names, companies, entities, or institutions. Any resemblance to any real person, 
company, entity, or institution is purely coincidental. 

Trademark Information  

Teamwork Server is registered trademark of Visual Paradigm.  
Sun, Sun ONE, Java, Java2, J2EE and EJB, NetBeans are all registered trademarks of Sun Microsystems, Inc. 
Eclipse is registered trademark of Eclipse. 
JBuilder is registered trademark of Borland Corporation. 
IntelliJ and IntelliJ IDEA are registered trademarks of JetBrains. 
Microsoft, Windows, Windows NT, Visio, and the Windows logo are trademarks or registered trademarks of Microsoft 
Corporation.  
Oracle is a registered trademark, and JDeveloper is a trademark or registered trademark of Oracle Corporation. 
BEA is registered trademarks of BEA Systems, Inc.  
BEA WebLogic Workshop is trademark of BEA Systems, Inc. 
Rational Rose is registered trademark of International Business Machines Corporation. 
WinZip is a registered trademark of WinZip Computing, Inc. 
Other trademarks or service marks referenced herein are property of their respective owners. 

Teamwork Server License Agreement 

THE USE OF THE SOFTWARE LICENSED TO YOU IS SUBJECT TO THE TERMS AND CONDITIONS OF THIS 
SOFTWARE LICENSE AGREEMENT. BY INSTALLING, COPYING, OR OTHERWISE USING THE SOFTWARE, YOU 
ACKNOWLEDGE THAT YOU HAVE READ THIS AGREEMENT, UNDERSTAND IT, AND AGREE TO BE BOUNDED 
BY ALL OF THE TERMS AND CONDITIONS OF THIS SOFTWARE LICENSE AGREEMENT. 

1. Limited License Grant. Visual Paradigm grants to you ("the Licensee") a personal, non-exclusive, non-transferable, 
limited, perpetual, revocable license to install and use Visual Paradigm Products ("the Software" or "the Product"). 
The Licensee must not re-distribute the Software in whole or in part, either separately or included with a product. 

2. Restrictions. The Software is confidential copyrighted information of Visual Paradigm, and Visual Paradigm and/or 
its licensors retain title to all copies. The Licensee shall not modify, adapt, decompile, disassemble, decrypt, extract, 
or otherwise reverse engineer the Software. Software may not be leased, rented, transferred, distributed, assigned, or 
sublicensed, in whole or in part. The Software contains valuable trade secrets. The Licensee promises not to extract 
any information or concepts from it as part of an effort to compete with the licensor, nor to assist anyone else in such 
an effort. The Licensee agrees not to remove, modify, delete or destroy any proprietary right notices of Visual 
Paradigm and its licensors, including copyright notices, in the Software. 

3. Disclaimer of Warranty. The software and documentation are provided "AS IS," WITH NO WARRANTIES 
WHATSOEVER. ALL EXPRESS OR IMPLIED REPRESENTATIONS AND WARRANTIES, INCLUDING ANY 
IMPLIED WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE OR 
NON-INFRINGEMENT, ARE HEREBY EXCLUDED. THE ENTIRE RISK AS TO SATISFACTORY QUALITY, 
PERFORMANCE, ACCURACY AND EFFORT IS WITH THE LICENSEE. THERE IS NO WARRANTY THE 
DOCUMENTATION, Visual Paradigm's EFFORTS OR THE LICENSED SOFTWARE WILL FULFILL ANY OF 
LICENSEE'S PARTICULAR PURPOSES OR NEEDS. IF THESE WARRANTIES ARE UNENFORCEABLE 
UNDER APPLICABLE LAW, THEN Visual Paradigm DISCLAIMS SUCH WARRANTIES TO THE MAXIMUM 
EXTENT PERMITTED BY SUCH APPLICABLE LAW. 

4. Limitation of Liability.  Visual Paradigm AND ITS LICENSORS SHALL NOT BE LIABLE FOR ANY 
DAMAGES SUFFERED BY THE LICENSEE OR ANY THIRD PARTY AS A RESULT OF USING OR 
DISTRIBUTING SOFTWARE. IN NO EVENT WILL Visual Paradigm OR ITS LICENSORS BE LIABLE FOR 
ANY LOST REVENUE, PROFIT OR DATA, OR FOR DIRECT, INDIRECT, EXEMPLARY, SPECIAL, 
CONSEQUENTIAL, INCIDENTAL OR PUNITIVE DAMAGES, HOWEVER CAUSED AND REGARDLESS OF 
THE THEORY OF LIABILITY, ARISING OUT OF THE USE OF OR INABILITY TO USE THE SOFTWARE, 
EVEN IF Visual Paradigm HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. 
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5. Termination.  The Licensee may terminate this License at any time by destroying all copies of Software. Visual 
Paradigm will not be obligated to refund any License Fees, if any, paid by the Licensee for such termination. This 
License will terminate immediately without notice from Visual Paradigm if the Licensee fails to comply with any 
provision of this License. Upon such termination, the Licensee must destroy all copies of the Software. Visual 
Paradigm reserves all rights to terminate this License. 

SPECIFIC DISCLAIMER FOR HIGH-RISK ACTIVITIES.  The SOFTWARE is not designed or intended for use in high-
risk activities including, without restricting the generality of the foregoing, on-line control of aircraft, air traffic, aircraft 
navigation or aircraft communications; or in the design, construction, operation or maintenance of any nuclear facility. Visual 
Paradigm disclaims any express or implied warranty of fitness for such purposes or any other purposes. 

NOTICE.  The Product is not intended for personal, family or household use; rather, it is intended exclusively for professional 
use. Its utilization requires skills that differ from those needed to use consumer software products such as word processing or 
spreadsheet software. 

GOVERNMENT RIGHTS.  If the Software is licensed by or on behalf of a unit or agency of any government, the Licensee 
agrees that the Software is "commercial computer software", "commercial computer software documentation" or similar terms 
and that, in the absence of a written agreement to the contrary, the Licensee's rights with respect to the Software are limited by 
the terms of this Agreement. 
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Chapter 1 - Introducing Teamwork Environment 

When several team members need to work on the same project, version control is 
always a major concern. The time and effort spent on merging the works of each 
team member is very expensive, and is very risky that the previous works may be 
overwritten by the new changes. 

Visual Paradigm's Teamwork Server automates these complex development 
processes, although its concept is very simple:  

 

Server-side: 

• The administrator creates teamwork users. 
• The administrator creates projects, and assigns selected users to the project. The read/update project permission is 

granted to users individually. 

Client-side: 

• The user logs in to the teamwork server. 
• The user checks out (download) a project from the server and opens it on the client side. 
• The user modifies the project locally, and then checks in (upload) the project to the server for updating. 
• If the user has been granted the update project permission, the server will compare the local project with the server 

project, and begin the two-phase checkin process. 
• The first phase checks whether conflicts are found. A conflict is the modification of a model/view element that is also 

modified by other teamwork users. If no conflict is found, the server proceeds to the second phase. Otherwise the 
teamwork client will notify the user of the conflicts, and ask him/her to select the conflict resolve method before 
proceeding to the second phase. 

• In the second phase, a new version of the project is created by merging the changes made by the user with the latest 
project copy on the server. 

• The new project is checked-out (downloaded) from the server to the client, and is reopened so that the user can work 
on the latest project. 



 

The Working Environment 2 
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Chapter 2 - Getting Started 

In order to get yourself ready for working with a Teamwork project, it is important to know how to checkout a project from the 
server, and familiar yourself with the Teamwork Client, a dialog box that enables you to browse the project and version detail 
and to perform various teamwork operations. This chapter provides everything you will need to know about getting started 
with the Teamwork Server environment. 

• Checkout a project from the server the first time 
• Introduction to the Teamwork Client 

Getting Started 

In order to work with a Teamwork project, you must checkout a copy from the server, and work with that copy. To checkout a 
project from the server: 

1. Open the Teamwork Client by selecting Tools > Teamwork > Open Teamwork Client... from the main menu. This 
shows the Login dialog box.  

 

Figure 2.1 - To open Teamwork Client 

 

For SDE and DBVA with IDE, right-click on the project node and select SDE-EC Project > 
Open Teamwork Client... from the popup menu. (The label of popup menu items may vary 
for different products)  

2. Enter the User name and enter the Password. Fill in the host name or IP address of the Teamwork Server in Server 
host. Enter the Port number. Click Login to login to the server.  

 

Figure 2.2 - Login to the Teamwork Server dialog 
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3. If the login success, the Teamwork Client appears. The accessible projects are listed under the Projects list. Select the 
project to work with.  

 

Figure 2.3 - Selecting a project to work with 

4. Checkout the selected project by performing any of the following:  
• Select Action > Checkout Project from the menu. 
• Click on the Checkout Project button on the toolbar. 
• Click on the Open Project button at the bottom right-hand corner.  

 

Figure 2.4 - To checkout a teamwork project 

5. Once the project is checked out, the Teamwork Client will be closed and the project will be opened immediately. 

Introduction to the Teamwork Client Dialog Box 

Besides checking out a project as described in the previous section, the Teamwork Client (dialog box) can also perform other 
kinds of teamwork operation such as versioning and committing projects. This section will describe the functionality of 
Teamwork Client by focusing on different parts of the Teamwork Client dialog box. 

 

Figure 2.5 - Teamwork Client 
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Main Menu and Toolbar 

The Teamwork Client window has a main menu bar and a toolbar for performing teamwork operations like login, checkout 
project, checkin project, check for update, refresh project list, import/export teamwork project and logout. 

 

Figure 2.6 - Main menu bar and toolbar 

Project List 

It displays a list of projects assigned to the user. 

 

Figure 2.7 - Project List 

Project Detail 

It displays the detailed information of the selected project. 

 

Figure 2.8 - Project Detail 

Field Description 

Project name The name of the project. 

File path The local file path of the project. This field is empty if the project is not yet checked out. 

Checkout time The last checkout time of the project. This field is empty if the project is not yet checked out. 

Version The teamwork project version. This field is empty if the project is not yet checked-out. 
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Status 

The project status. Possible status are: 

Not checked out - The project is not yet checked out. 

Up-to-date (local project not modified) - The project is up-to-date, and the local project file is 
not modified since the last checkout. 

Up-to-date (local project modified) - The project is up-to-date, and the local project file is 
modified since the last checkout. 

Has update (local project not modified) - A newer version of the project is available on the 
server, and the local project file is not modified since the last checkout. 

Has update (local project modified) - A newer version of the project is available on the 
server, and the local project file is modified since the last checkout. 

Error in checking project status - The project status cannot be determined. You should check 
out the project again if you see this status. 

Not connected to the teamwork server - The current client session is no longer valid. You 
should re-connect to the Teamwork Server if you see this status. 

 
The project status is refreshed automatically when a project is 
selected in the project list.   

Description Displays the project description. 

Delete local project file 
when logout 

Delete the local project file when logged out of the Teamwork Server. 

Open Project 
Click this button to open the project in VP-UML/SDE/DB-VA/BP-VA for viewing or 
editing. 

Versions 

It displays the version history of the selected project. 

 

Figure 2.9 - Versions 
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Status Bar 

The status bar displays information or error messages generated by the Teamwork Client. 

 

Figure 2.10 - Status Bar 

 



 

Running the Client 3 
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Chapter 3 - Running the Client 

From VP-UML 

To open Teamwork Client in VP-UML, perform one of the following actions: 

• Select the Tools menu > Teamwork > Open Teamwork Client.... 

 

Figure 3.1 - Launch Teamwork Client in Visual Paradigm for UML 

• Click on the Open Teamwork Client button on the toolbar. 

 

Figure 3.2 - Open Teamwork client button on the Toolbar 

The Login to the Teamwork Server dialog box shows. Please read the section Logging in to the Teamwork Server for details. 
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From SDE 

Visual Studio .NET 

• Right-click on project node inside the Solution Explorer and select SDE-VS Project > Open Teamwork Client... 
from the popup menu. 

The Login to the Teamwork Server dialog box shows. Please read the section Logging in to the Teamwork Server for 
details. 

Eclipse 

• Right-click on project node inside the Package Explorer and select SDE-EC Project > Open Teamwork Client... 
from the popup menu. 

 

Figure 3.3 - Open Teamwork Server Client in SDE 

The Login to the Teamwork Server dialog box shows. Please read the section Logging in to the Teamwork Server for 
details. 
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JBuilder 

• Right-click on the project node inside the Project pane and select SDE %EDITION% -JB Project > Open 
Teamwork Client... from the popup menu. 

The Login to the Teamwork Server dialog box shows. Please read the section Logging in to the Teamwork Server for 
details. 

NetBeans/Sun ONE 

• Select the Tools menu > SDE %EDITION% -NB > SDE %EDITION% -NB Project > Open Teamwork Client.... 
• Right-click on the project node inside the Projects pane and select Tools > SDE %EDITION% -NB > SDE 

%EDITION% -JB Project > Open Teamwork Client... from the popup menu. 

The Login to the Teamwork Server dialog box shows. Please read the section Logging in to the Teamwork Server for 
details. 

IntelliJ IDEA 

• Right-click on the project node inside the Project pane and select SDE %EDITION% -IJ > SDE %EDITION% -IJ 
Project > Open Teamwork Client... from the popup menu. 

The Login to the Teamwork Server dialog box shows. Please read the section Logging in to the Teamwork Server for 
details. 

JDeveloper 

• Right-click on the project node inside the Application - Navigator pane and select SDE %EDITION% -JD Project 
> Open Teamwork Client... from the popup menu. 

The Login to the Teamwork Server dialog box shows. Please read the section Logging in to the Teamwork Server for 
details. 

WebLogic Workshop 

• Right-click on the project node inside the Application  pane and select SDE-WW Project > Open Teamwork 
Client... from the popup menu. 

The Login to the Teamwork Server dialog box shows. Please read the section Logging in to the Teamwork Server for 
details. 
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From DB-Visual Architect 

Standalone DB-VA 

To open Teamwork Client in DB-VA, perform one of the following actions: 

• Select the Tools menu > Teamwork > Open Teamwork Client.... 

 

Figure 3.4 - Launch Teamwork Server Client in Database Visual Architect 

• Click on the Open Teamwork Client button on the toolbar. 

 

Figure 3.5 - Open Teamwork Client button in the toolbar of DB-VA 

The Login to the Teamwork Server dialog box shows. Please read the section Logging in to the Teamwork Server for details. 
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DB-VA for IDE 

Eclipse  

• Right-click on project node inside the Package Explorer and select DBVA-EC Project > Open Teamwork Client... 
from the popup menu. 

 

Figure 3.6 - Launch Teamwork Client in DBVA-EC 

The Login to the Teamwork Server dialog box shows. Please read the section Logging in to the Teamwork Server for 
details. 

JBuilder 

• Right-click on the project node inside the Project pane and select DBVA %EDITION% -JB Project > Open 
Teamwork Client... from the popup menu. 

The Login to the Teamwork Server dialog box shows. Please read the section Logging in to the Teamwork Server for 
details. 



Teamwork Server Client User’s Guide  Chapter 3 – Running the Client 

 

3-7 

NetBeans/Sun ONE 

• Select the Tools menu > DBVA %EDITION% -NB > DBVA %EDITION% -NB Project > Open Teamwork 
Client... . 

• Right-click on the project node inside the Projects pane and select Tools > DBVA %EDITION% -NB > DBVA 
%EDITION% -JB Project > Open Teamwork Client... from the popup menu. 

The Login to the Teamwork Server dialog box shows. Please read the section Logging in to the Teamwork Server for 
details. 

IntelliJ IDEA 

• Right-click on the project node inside the Project pane and select DBVA %EDITION% -IJ > DBVA 
%EDITION% -IJ Project > Open Teamwork Client... from the popup menu. 

The Login to the Teamwork Server dialog box shows. Please read the section Logging in to the Teamwork Server for 
details. 

JDeveloper 

• Right-click on the project node inside the Application - Navigator pane and select DBVA %EDITION% -JD 
Project > Open Teamwork Client... from the popup menu. 

The Login to the Teamwork Server dialog box shows. Please read the section Logging in to the Teamwork Server for 
details. 

WebLogic Workshop 

• Right-click on the project node inside the Application  pane and select DBVA -WW Project > Open Teamwork 
Client... from the popup menu. 

The Login to the Teamwork Server dialog box shows. Please read the section Logging in to the Teamwork Server for 
details. 
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Logging in to the Teamwork Server 

When the Login to the Teamwork Server dialog box appears, do the following to login to the Teamwork Server: 

1. Enter your user name in the User name field. 
2. Enter your password in the Password field. 
3. Enter the IP address of the Teamwork Server in Server host. 
4. Enter the port number of the Teamwork Server in Port number. 
5. Select Remember password if you do not want to enter the password every time. 
6. If you use proxy server for connection, select Use proxy and fill in the host and port of the proxy server in Proxy host 

and Port respectively. 
7. Click Login to login to the Teamwork Server. 

 

Figure 3.7 - Login to the Teamwork Server dialog 

 
The default port number of the Teamwork Server is 1999.  

Logging out the Teamwork Server 

When you finished your teamwork project, you can logout the teamwork working environment. To logout the Teamwork 
Client, open the Teamwork Client and perform one of the following actions: 

• Select the Session menu > Logout 
• Click on the Logout button on the toolbar 

 
If you exit from the application, you will be logged out of the Teamwork Client automatically.  

 
After you have logged out the Teamwork Client, you can select the Session menu > Login or 
click on the Login button on the toolbar to login again.  

 



 

Updating a Project 4 
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Chapter 4 - Updating a Project 

The update project function update the project by downloading changes made by other team members from the Teamwork 
Server to the client's computer. 

To update a project: 

1. Open the Teamwork Client by selecting Tools > Teamwork > Open Teamwork Client... from the main menu. This 
starts the Teamwork Client.  

 

Figure 4.1 - To open Teamwork Client 

 

For SDE and DBVA with IDE, right-click on the project node and select SDE-EC Project > 
Open Teamwork Client... from the popup menu. (The label of popup menu items may vary 
for different products)  

2. Update the project by performing any of the following:  
• Select Action > Update Project from the menu. 
• Click on the Update Project button on the toolbar.  

 

Figure 4.2 - To update a Teamwork Project 

3. If the Project Modified Locally  dialog box appear, this means that there are local changes that have not yet been 
committed to the server. To checkin the project before updating it, choose Yes. It is advised that you choose this 
option to avoid lossing of data. Choosing No will go straight to updating the project. All the local changes will be 
discarded. To withdraw from update, choose Cancel. 

 

Figure 4.3 - The Project Modified Locally dialog box 

 



 

Committing a Project 5 
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Chapter 5 - Committing a Project 

The checkin project function allows you to commit the project changes (that you have made to the local project) to the 
Teamwork Server. 

 
The commit project function is enabled only if the project is opened through the Teamwork 
Client.  

To commit project: 

1. Open the Teamwork Client. The way of opening a project vary with the product that you are using. Read Chapter 3 
for how to run the Teamwork Client. 

2. Perform one of the following: 

• Select Action > Checkin Project from the menu.  

 

Figure 5.1 - To commit a Teamwork Project 

• Click on the Checkin Project button on the toolbar. 

This shows the Commit Project dialog box.  

3. Enter a description before committing. Click OK  to proceed with checking the models to be committed.  

 

Figure 5.2 - The Commit Project dialog box 
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4. In the Commit Models(s) dialog box, resolve any conflict, then click OK  to proceed with committing the changes to 
the server. More about resolving conflicts will be explained later in this chapter.  

 

Figure 5.3 - The Commit Model(s) dialog box 

You can also use menu or toolbar to commit project, the methods vary with the product you are using, which are described 
below. 

VP-UML, DB-VA (standalone), BP-VA, AG 

Perform one of the following: 

• Select Tools > Teamwork > Commit... from the main menu. 
• Click on the Commit Project button on the toolbar. 

SDE 

IDE Methods to commit project 

Visual Studio 
.NET 

Right-click on project node inside the Solution Explorer and select SDE-VS Project > Commit Project... 
from the popup menu. 

Eclipse  
Right-click on project node inside the Package Explorer and select SDE-EC Project > Commit Project... 
from the popup menu. 

JBuilder 
Right-click on the project node inside the Project pane and select SDE %EDITION% -JB Project > 
Commit Project... from the popup menu. 

NetBeans/Sun 
ONE 

Perform any of the following 

• Select Tools > SDE %EDITION% -NB > SDE %EDITION% -NB Project > Commit Project... 
from the main menu. 

• Right-click on the project node inside the Projects pane and select Tools > SDE %EDITION% -
NB > SDE %EDITION% -JB Project > Commit Project... from the popup menu. 

IntelliJ IDEA 
Right-click on the project node inside the Project pane and select SDE %EDITION% -IJ > SDE 
%EDITION% -IJ Project > Commit Project... from the popup menu. 

JDeveloper 
Right-click on the project node inside the Application - Navigator pane and select SDE %EDITION% -
JD Project > Commit Project... from the popup menu. 
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WebLogic 
Workshop 

Right-click on the project node inside the Application  pane and select SDE-WW Project > Commit 
Project... from the popup menu. 

Table 5.1 

DBVA with IDE 

IDE Methods to commit project 

Visual Studio 
.NET 

Right-click on project node inside the Solution Explorer and select DBVA-VS Project > Commit 
Project... from the popup menu. 

Eclipse  
Right-click on project node inside the Package Explorer and select DBVA-EC Project > Commit 
Project... from the popup menu. 

JBuilder 
Right-click on the project node inside the Project pane and select DBVA %EDITION% -JB Project > 
Commit Project... from the popup menu. 

NetBeans/Sun 
ONE 

Perform any of the following 

• Select Tools > DBVA %EDITION% -NB > DBVA %EDITION% -NB Project > Commit 
Project... from the main menu. 

• Right-click on the project node inside the Projects pane and select Tools > DBVA 
%EDITION% -NB > DBVA %EDITION% -JB Project > Commit Project... from the popup 
menu. 

IntelliJ IDEA 
Right-click on the project node inside the Project pane and select DBVA %EDITION% -IJ > DBVA 
%EDITION% -IJ Project > Commit Project... from the popup menu. 

JDeveloper 
Right-click on the project node inside the Application - Navigator pane and select DBVA %EDITION% -
JD Project > Commit Project... from the popup menu. 

WebLogic 
Workshop 

Right-click on the project node inside the Application  pane and select DBVA-WW Project > Commit 
Project... from the popup menu. 

Table 5.2 

Conflict Resolution 

When you commit the changes to the server, it may cause a conflict. A conflict occurs when the changes you made cause 
conflicts with the changes made by and committed by another team member. The Commit Model(s) dialog box, shows during 
the commit, provide all the functions you need to resolve conflicts. 

To identify and resolve a conflict: 

1. Find out a conflict by performing any of the following:  
• Select an item with the cross sign added. The cross sign indicates that there is a conflict for that item.  

 

Figure 5.4 - A conflict occurs 
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• Click the Select next conflict button on the function bar.  

 

Figure 5.5 - To advance to the next conflict, if any 

2. This shows the detail of changes on the right-hand side of the dialog box. 

 

Figure 5.6 - Information about the conflict 

3. Here are some common fields that describe the changes: 

Field Description 

Name The updated name of the affected model, in the local copy. 

Original 
Name 

The name of the affected model before changed, in the local copy. 

Conflict 
Name 

The updated name of the affected model, in the remote copy. 

Value The updated value of the affected property, in the local copy. 

Original 
Value 

The value of the affected property before changed, in the local copy. 

Conflict 
Value 

The updated value of the affected property, in the remote copy. 

Version 
The updated version of this change. It is Local by default. If the way of resolving this conflict is set 
to be Revert, the version will become the conflict version. 

Conflict 
Version 

The version of project, stored in server, that causes conflict with the commit. 

Table 5.3 
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4. After a conflict is identified, you need to either overwrite or to revert the modification. Commit will not proceed when 
there exists an unresolved conflict. 

There are two buttons under the description of change, Overwrite  and Revert. To overwrite the modifications made 
by other team members, click Overwrite . To apply the modification made by other team members, click Revert.  
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Chapter 6 - Refreshing the Project Listing 

Refresh project list allows you to refresh the list of projects available to you. This is particularly useful when the administrator 
has assigned new projects to you after you have logged in. 

To refreshing the project listing: 

1. Open the Teamwork Client. The way of opening a project vary with the product that you are using. Read Chapter 3 
for how to run the Teamwork Client. 

2. Perform one of the following: 

• Select Action > Refresh Project from the menu. 
• Click on the Refresh Project button on the toolbar. 
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Chapter 7 - Exporting and Importing a Project 

Exporting a Teamwork Project 

If you want to carry the teamwork project to another computer for editing where the Teamwork Server is not available, you can 
use the export project function. After you have modified the project, you can use the import project function (described in the 
Importing a Teamwork Project section) to commit the changes you have made to the Teamwork Server once it is available. 

To export a project: 

1. Open the Teamwork Client. The way of opening a project vary with the product that you are using. Read Chapter 3 
for how to run the Teamwork Client. 

2. Perform one of the following: 

• Select Action > Export Teamwork Project from the menu. 
• Click on the Export Teamwork Project button on the toolbar.  

 

Figure 7.1 - To export a Teamwork Project 

3. When the Export Teamwork Project file dialog box appears, specify the location and file name of the exported 
project, then click Save to confirm. 

Importing a Teamwork Project 

If you want to carry the teamwork project to another computer for editing where the Teamwork Server is not available, you can 
use the export project function (described in the Exporting a Teamwork Project section). After you have modified the 
project, you can use the import project function to commit the changes you have made to the Teamwork Server once it is 
available. 

To import a project: 

1. Open the Teamwork Client. The way of opening a project vary with the product that you are using. Read Chapter 3 
for how to run the Teamwork Client. 

2. Perform one of the following: 

• Select Action > Import Teamwork Project  from the menu. 
• Click on the Import Teamwork Project  button on the toolbar. 

3. When the Import Teamwork Project  file dialog box appears, select the project file to import and then click Open to 
continue. The imported project will be checked-in to the server automatically. 

 
Only projects exported using the export project function can be imported into the Teamwork 
Server.  
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Chapter 8 - Versioning 

Showing versions 

To view the version history of a project: 

1. Open the Teamwork Client. The way of opening a project vary with the product that you are using. Read Chapter 3 
for how to run the Teamwork Client. 

2. Select the Versions tab. 

 

Figure 8.1 - To select the Versions tab 

3. Select a version in the Project versions list and the detailed information are shown. 

 

Figure 8.2 - Version page 

Field Description 

Display Select the number of latest versions to display in the Project versions list. 

Project versions 
A list of project versions, which shows the version number, checkin user name and 
checkin date time of each version. 

Open Project 
Click this button to open the project for viewing (modifications are not allowed to commit 
to the Teamwork Server). 

Checkin Description The description (reason) entered for the checkin. 

Modified model 
elements 

A list of modified model elements in this version. 

Modified diagrams A list of modified diagrams in this version. 

Modified diagram 
elements 

A list of modified diagram elements in this version. 

Conflicts A list of conflicts found during the checkin process of this version. 

Table 8.1 


