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Chapter 2 - Working with Diagrams 

SDE for Eclipse is a visual modeling tool that provides all well-known modeling toolsets to cover all aspects of modeling and 
documentation, from business process modeling to detailed system specification. SDE for Eclipse supports more than 20 
diagram types including all diagram types in UML, BPMN, SysML, ERD, DFD and more. Visual Paradigm strives to 
continuously enhance the diagramming environment to increase effectiveness and efficiency of modeling, as when using SDE 
for Eclipse, most of your working time is with diagrams. 

 

  In this chapter you will learn: 

·  Creating Diagram 
·  Creating Diagram Elements and connecting them 
·  Basic Diagram editing 
·  Different Copy and Paste strategies 
·  Grouping Diagram Elements for easier management 
·  Some diagramming techniques 

 
Figure 2.1 - Diagram pane 
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Creating Diagram 

You can create diagrams in different ways: 

·  Using toolbar 
·  Using popup menu of Diagram Navigator 

To use toolbar to create: 
Click on the icon on the toolbar and select the diagram you want to create from the dialog box. 

 
Figure 2.2 - New Class Diagram icon on the toolbar 
 

 
Figure 2.3 - Select New SDE EE-EC Diagram 
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To use the popup menu of Diagram Navigator to create: 
Right click on the diagram type node in Diagram Navigator and select New Class Diagram in popup menu. 

 
Figure 2.4 - Select New Class Diagram from popup menu of Diagram Navigator 

Creating Diagram Elements 

After creating a new diagram, you can create diagram elements using the diagram toolbar. In this section, we will introduce the 
techniques of how to create diagram elements and connectors: 

·  Creating Shapes  
·  Creating Connectors  
·  Creating Self-Connection 

Creating Shapes 

To create a shape, click on a diagram element button from the diagram toolbar and click on the diagram pane to create it. The 
element generated will have a default size. 

 

Figure 2.5 - Click to Create Shapes 
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You can also drag a specific boundary before releasing the mouse to define a shape's initial size. 

 
Figure 2.6 - Create Shapes with specific size 

 

Alternatively, you can also create a diagram element by dragging a diagram element button then dropping it on the diagram 
pane. 

 
Figure 2.7 - Drag and drop to Create Shapes 

 

Apart from that, you can use the diagram popup menu to add a shape. 

 
Figure 2.8 - Create Shapes using diagram popup menu 
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Creating Connectors 

To create a connector, select the desired connector from the diagram toolbar and click on the source shape. Drag the connector 
to the destination shape. 

SDE for Eclipse provides continuous UML syntax checking. You will see a stop sign when you try to create an invalid 
connection, e.g. you cannot create a generalization relationship between an actor and a use case. 

 

Figure 2.9 - Try to create an invalid connection 

If the connection is valid you will see a blue rounded rectangle surrounding the destination shape. 

 

Figure 2.10 - Try to create a valid connection 

 

You may also use resource to create connectors. 
Click on the Association resource of a shape and drag over the shape you want to connect to. If you release the mouse on an 
empty space, a shape will be created with the connector. 

 
 

Figure 2.11 - Click on resource Figure 2.12 - Drag over the shape 

Creating Self-Connection 

Some of the shapes can have a connection to itself, for example Self-Association of a Class or Self-Link of an Object in a 
Communication Diagram. To create a self-connection, click on the connector button on the diagram toolbar and click once on 
the target object. 

Alternatively, you can click on the Self Association resource. 

  

Figure 2.13 - Create Self-Connection Figure 2.14 - Self-Connection 
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Resource-Centric Interface 

Visual Paradigm is the first vendor to introduce the resource centric diagramming interface. The resource centric interface 
greatly improves the efficiency of modeling. You no longer needs to go back and forth between the toolbar and the diagram to 
create diagram elements, make connections and modify the diagrams. The resource centric interface can make sure the modeler 
is able to create a diagram with correct syntax more quickly. 
There are three types of resource: 

·  Connection Resource 
·  Manipulation Resource 
·  Branching Resource 

Connection Resource 

It is designed for creating elements and making connections. Here, the connection between an actor and a use case is used as an 
example. 
To use Connection Resource: 
1. Move mouse over Association - > Use Case resource. 

 
Figure 2.15 - Association - > Use Case resource 
 

2. Drag resource to empty space on diagram pane. 

 
Figure 2.16 - Drag resource 

 

3. Release the mouse, new connector and shape are created. 

 
Figure 2.17 - Connector and shape created 
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Manipulation Resource 

You can use Manipulation Resource to modify properties or appearance of elements. For example, you can show or hide 
compartments, add references, add sub-diagram and fit size. 
To use Manipulation Resource, simply click once on it. 

 
Figure 2.18 - Reference of Manipulation Resource 

Branching Resource 

Branching Resource helps you to create decision structure in diagram. 
To use branching resource: 
1. Move mouse over a Branching Resource. 

 
Figure 2.19 - Branching Resource 
 

2. Drag resource to empty space on diagram. 

 
Figure 2.20 - Drag resource 
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3. Release mouse, a branch is created. 

 
Figure 2.21 - Create branch 

 

Alternatively, if a shape in the branch already exists, you can drag the resource over it. 

 
Figure 2.22 - Drag resource over existed shape 
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When mouse is released, a branch is created involving the target shape. 

 
Figure 2.23 - Create branch 

 

 

Enabling/Disabling the Resource-Centric Interface 

To enable/disable the resource centric interface feature, select/deselect menu Format > Resource Centric. This option will be 
applied to all diagrams. 

 
Figure 2.24 - Enable/Disable Resource Centric 

Interface 
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Enabling/Disabling Group Resource-Centric Interface 

Group resources appear when two or more shapes are selected. They are used to perform actions on the selected shapes, e.g. 
alignment and distribute shapes. 
To enable/disable, select/deselect Modeling > Application Options... to open the Options dialog box, select Diagramming > 
Resource Centric tab. This option will be applied to all diagrams. 

 
Figure 2.25 - Group Resources Centric Interface for use case 
 

Show Extra Resources 

By default the resource centric interface displays the most commonly used resources of a diagram element. You can choose to 
view less common resourcesby clicking on the Format > Show Extra Resources in the main menu. The figures below show 
the view of a Action element with "Show Extra Resources" turned off and on. 

 
 

Figure 2.26 - Resource-Centric of Action Figure 2.27 - Action with an Extra Resource-Centric 

 

Show Generic Resource-Only 

Generic Resource is a special kind of resource in the Resource-Centric Interface. Unlike other resources, the type of the 
connector and/or shape type that will be created is undetermined, you will be asked for the desired connector/shape type when 
the creation is confirmed. 
To show/not to show Generic Resource Only, select Modeling > Application Options... to open the Options dialog box, select 
Diagramming > Resource Centric tab. 

 

 
Figure 2.28- Show Generic Resources-Only 
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Basic Editing 

Multiple Selection 

Multiple selection can be made with mouse alone or with keyboard and mouse. 
With mouse alone: 
Click on an empty space of the diagram and drag to include desired shapes in the dashed-line rectangle. 

 
Figure 2.29 - Multiple selection using mouse 

 

With keyboard and mouse: 
With the Shift or Ctrl  key held down, click on the shapes to select them. After selecting a shape, you may click it again to 
deselect it. 

 
Figure 2.30 - Multiple selection using mouse and keyboard 
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Moving Shape 

SDE for Eclipse diagram editor supports true WYSIWYG diagram editing. You can move shapes with the mouse or keyboard. 
 
With mouse: 
Click on a shape to drag it to the desired direction to move it. 

  
Figure 2.31 - Shape before moving to the right Figure 2.32 - Shape after moving to the right 

 

With keyboard: 
1. Select shape(s) which you want to move. 
2. Press the up/down/left/right  arrow key to move the shape(s). 

Moving Shape in One Direction 

Instead of moving shapes in any direction, you may restrict the shapes to move in one direction only for easier alignment, i.e. 
you may move the shapes vertically or horizontally, but not diagonally. 
This can be done by pressing Shift key while dragging the shapes.  

 
Figure 2.33 - Restrict moving direction 

 

Delete 

The main difference between CASE Tool and drawing tools is that CASE Tool has a Model and View concept. The model is 
where information is stored, while the view is a presentation of the model. A model can have multiple views, for example, you 
can show the same class in different class diagrams. Upon pressing 'delete', SDE for Eclipse will assume you are deleting the 
view of the model, but will prompt you to delete the model if all views of a specific model are deleted. This section will show 
you how to delete models and views. 
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Delete 

To delete view together with model: 
1. perform one of the following action: 

·  Select Delete > Delete in the popup menu of that element. 
·  Press the Delete button on the keyboard. 

 
Figure 2.34 - Select Delete 

 
2. A Delete dialog box will display and ask you if you want to delete. Click Yes to confirm. If you want to set this option as 
default, check Use this option as default and don't ask again. 

 
Figure 2.35 - Delete dialog box for confirming deleting 
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3. If there is no referenced view other than deleted view, the Delete dialog will ask you if you want to delete the model from 
the repository. Click Yes to confirm. If you delete more than one diagram element at one time, you may click Yes to all to 
confirm. 

 
Figure 2.36 - Confirm deleting from the repository 

 

Delete View Only 

To delete view(diagram element of model) only: 
1. Select Delete > Delete View Only in the popup menu of that element. 

 
Figure 2.37 - Select Delete View Only 
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2. A Delete dialog box will display and ask you if you want to delete. Click Yes to confirm. If you want to set this option as 
default, check Use this option as default and don't ask again. 

 
Figure 2.38 - Delete dialog box to confirm deleting 

 

Copy and Paste 

Copy 

SDE for Eclipse support various copy and paste options. By default your copy will only within SDE for Eclipse and will not 
affect the content in your system clipboard. If you want to copy the content to other application, you can copy to clipboard as 
image then you can paste your design to other application. This section, we will show you different copy and pasts options 
SDE for Eclipse provides. 

Copy within SDE-EC 
Copying diagram elements within SDE-EC allows you to copy selected diagram elements to the application clipboard. You can 
paste the diagram elements to other SDE-EC diagrams from the current project or across another project.  

 
You cannot paste the selected content to other applications. 

To copy selected diagram elements within SDE-EC, perform one of the following actions: 

·  Select Edit > Copy from main menu.  
·  Right-click on the selected diagram elements and choose Copy > Copy within SDE EE-EC from popup menu.  
·  Press Ctrl-C. 

Copy within SDE-EC is the default copy action. For more details about the default copy action, please reference to the section 
"Setting Default Copy Action" below. 

Copying to the Clipboard as Image (JPG) 

 
Copying diagram elements as JPG image will copy the selected diagram element as a JPG image to the system clipboard, 
which you can copy to other applications.  

To copy selected diagram elements to the system clipboard as JPG image, perform one of the following actions: 

·  Select Edit > Copy to Clipboard as Image (JPG) from main menu.  

·  Click on the Copy drop down button on the toolbar and select Copy to Clipboard as Image (JPG) from the drop 
down menu. 

·  Right-click on the selection and choose Copy > Copy to Clipboard as Image (JPG) from popup menu.  
·  Press Ctrl-Alt-C.  
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Copying to the Clipboard as Image (EMF) 

 
Copying diagram elements as EMF (Enhanced Metafile) image will copy the selected diagram element as an EMF image to the 
system clipboard, which you can copy to other applications. Unlike copy as JPG image, the copied content is in EMF format, 
which is a more scalable format where image quality can be retained even after being resized/zoomed. 

 
The copy to system clipboard as EMF image feature is available on Windows platforms only. 

To copy selected diagram elements to the system clipboard as EMF image, perform one of the following actions: 

·  Select Edit > Copy to Clipboard as Image (EMF) from main menu.  

·  Click on the Copy drop down button on the toolbar and select Copy to Clipboard as Image (EMF) from the drop 
down menu. 

·  Right-click on the selection and choose Copy > Copy to Clipboard as Image (EMF) from popup menu.  
·  Press Ctrl-Alt-Shift-C. 

Setting Default Copy Action 
The default copy is triggered when the hotkey Ctrl + C is pressed. The actual action performed by default copy follows the 
SDE for Eclipse application option (as configured in the Options dialog box -> Diagramming category -> Environment page). 
The default copy action can be set to one of the following: 

·  Copying within SDE-EC  
·  Copying to Clipboard as OLE 
·  Copying to Clipboard as Image (JPG)  
·  Copying to Clipboard as Image (EMF) 

Paste 

You can select different paste methods according to what you have copied. 

Pasting View 
The pasted diagram elements share the same content of the copied diagram elements. Any changes made on the pasted 
elements will result in the same changes appearing on the elements copied, as the model elements are shared on the diagram 
elements. 

To paste diagram element with model sharing, perform one of the following actions: 

·  Select Edit > Paste from main menu.  

·  Right-click on the target diagram and choose Paste View from popup menu. 
·  Press Ctrl-V  

Pasting Model 
It clones a copy of the copied diagram elements and the model element, then pastes them to the diagram. It is enabled to copy 
within SDE-EC. 

To paste diagram element without model sharing, perform one of the following actions: 

·  Right-click on the target diagram and choose Paste Model from popup menu. 



SDE User’s Guide (Part 1)  Chapter 2 – Working with Diagrams 

 

2-18 

Pasting as Image Shape 
With image shape, you can easily annotate and document your diagrams with related images. Instead of creating an image 
shape manually, you can copy an image from any application to the clipboard and then paste it to the diagram as a new shape. 

 

Figure 2.39 - Paste as Image Shape 

To paste an image shape, perform one of the following actions: 

·  Select Edit > Paste from main menu.  

·  Right-click on the target diagram and choose Paste View from popup menu. 
·  Press Ctrl-V 

Undo/Redo 

When you create and edit a diagram, you may make mistakes like accidentally deleting a diagram element. You can use the 
Undo function to cancel the previous action. On the other hand, you may re-perform the action using the Redo action. The 
undo/redo feature in SDE for Eclipse is diagram based. 

Undo 

You can roll back undesirable changes by performing Undo. To undo an action, perform one of the following actions: 

·  Select Edit > Undo from main menu.  
·  Press Ctrl-Z.  

Redo 

This feature is to re-perform actions that were just undone. To redo an action, perform one of the following actions: 

·  Select Edit > Redo from main menu.  
·  Press Ctrl-Y.  
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Grouping 

After you have applied alignment to a group of shapes, you may want to keep its configuration and not want them to get 
messed up. Grouping feature is designed for this usage. After shapes are grouped, you can treat the grouped shapes as a single 
shape. 
In SDE for Eclipse, you can perform multiple level grouping - that is, group a shape with other shapes, and even with other 
groups. 

Grouping Shapes 

To group shapes, select shapes in the diagram and perform one of the following actions: 

·  Select menu Edit > Group. 
·  Right-click on the selection and select Grouping > Group from the popup menu.  

Ungrouping Shapes 

To ungroup shapes, select the grouped shapes in the diagram and perform one of the following actions: 

·  Select menu Edit > Ungroup. 
·  Right-click on the selection and select Grouping > Ungroup from the popup menu. 
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Resizing Shapes in Group 

In some cases, you may want to resize multiple shapes on the diagram, SDE for Eclipse allows you to resize the shapes in a 
group, which in turn reduces the handling time for resizing the shapes individually. When you resize one shape of the selected 
shapes, all the selected shapes will resize by the same amount, regardless of their original sizes. 
To resize the shapes in a group: 

1. Select multiple desired shapes on the diagram. 

 

 

Figure 2.40 - Multiple desired shapes on diagram 
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2. Resize one of the selected shapes. All selected shapes will resize proportionally. 

 

Figure 2.41 - Resize one of the selected shapes. All selected shapes will resize proportionally 

 
If the size of the resizing shape returns to its original shapes before resizing, all selected shapes will not 
resize accordingly 
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Reversing Connector Direction 

Reverse Connector can be used to reverse the direction of connector. 

Here, the direction of connector between Shipper and FAS Online System is inverted. 

 
Figure 2.42 - Before reversing Connector Direction 

 

To reverse the connector, right-click on the connector and select Reverse Connector from the popup menu. 

 
Figure 2.43 - Select Reverse Connector 

  

The direction of connector is now inverted.  

 
Figure 2.44 - After reversing Connector Direction 
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Grid 

Showing/Hiding Grids 

To toggle the visibility of grid lines, perform one of the following actions: 

·  Check/Uncheck Format > Show Grid from main menu to show/hide grid lines. 

 
Figure 2.45 - Select Grid 
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·  Right-click on the target diagram, check/uncheck Grid > Grid Visible  from popup menu to show/hide grid lines. 

 
Figure 2.46 - Select Grid Visible 

·  From the property table, check/uncheck Visible under Grid  heading to show/hide grid lines. 

 
Figure 2.47 - Check Visible 
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·  Right-click on the target diagram and choose Open Specification from popup menu. This displays the Diagram 
Specification dialog box. From the dialog box, switch to Grid Setting tab and check/uncheck Grid Visible  to 
show/hide grid lines. 

 
Figure 2.48 - Check Grid visible 
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Snap to Grid 

This feature is used to set whether diagram elements should stick to grid lines when moving in the diagram. To turn the option 
on/off, perform one of the following actions: 

·  Check/Uncheck Format > Snap to Grid from main menu to turn on/off the snap to grid option. 

 
Figure 2.49 - Select Snap to Grid 
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·  Right-click on the target diagram, check/uncheck Grid > Snap to Grid from popup menu to turn on/off the snap to 
grid option. 

 
Figure 2.50 - Select Snap to Grid using popup menu 

·  From the property table, check/uncheck Snap to Grid under Grid  heading to turn on/off the snap to grid option. 

 
Figure 2.51 - Select Snap to grid 
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·  Right-click on the target diagram and choose Open Specification from popup menu. This displays the Diagram 
Specification dialog box. From the dialog box, switch to Grid Setting tab and check/uncheck Snap to Grid to turn 
on/off the snap to grid option. 

 
Figure 2.52 - Check Snap to grid in Specification 

Grid Size 

To adjust the grid size, perform one of the following actions: 

·  From the property table, enter the value for Width and Height property under Grid  heading. 

 
Figure 2.53 - Adjust grid size in property table 
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·  Right-click on the target diagram and choose Open Specification from popup menu. This displays the Diagram 
Specification dialog box. From the dialog box, switch to Grid Setting tab and enter the value for Width and Height. 

 
Figure 2.54- Adjust grid size in specification 
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Grid Color 

To adjust the grid color, perform one of the following actions: 

·  Right-click on the target diagram and select Grid > Grid Color... from the popup menu. This displays the Select Grid 
Color dialog box for setting the grid color. 

 
Figure 2.55 - Select Grid Color 

·  From the property table, click the ... button in the Value column of Color property under Grid  heading. This displays 
a color chooser for selecting a grid color 

 
Figure 2.56- Select Color 
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·  Right-click on the target diagram and choose Open Specification from the popup menu. This displays the Diagram 
Specification dialog box. From the dialog box, switch to Grid Setting tab, click on the button ...from the Grid Color 
field and select the grid color from the drop-down color chooser. 

 
Figure 2.57- Select Grid Color 

 
The grids must be visible before setting the grid color. 

Zooming 

Zooming In 

The zoom in feature allows you to get a close-up view of the diagram. To perform zoom in, perform one of the following 
actions: 

·  Select Format > Zoom > Zoom in from main menu.  

·  Click on the Zoom In button on the toolbar.  
·  Right-click on the target diagram and choose Zoom > Zoom In from the popup menu. 
·  Press Ctrl-= (Ctrl-Equals). 
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Zooming Out 

The zoom out feature allows you to see more of the diagram at a reduced size. To perform zoom out, perform one of the 
following actions: 

·  Select Format > Zoom > Zoom Out from main menu.  

·  Click on the Zoom Out button on toolbar.  
·  Right-click on the target diagram and choose Zoom > Zoom Out from popup menu. 
·  Press Ctrl-- (Ctrl-Minus). 

Zooming to 100% 

The zoom to 100% feature allows you to view the diagram in its actual size (100%). To restore the zoom ratio to 100%, 
perform one of the following actions: 

·  Select Format > Zoom > Zoom 100% from main menu.  

·  Click on the Zoom 100% button on toolbar.  
·  Right-click on the target diagram and choose Zoom > Zoom 100% from popup menu.  
·  Press Ctrl-0. 

Zooming to a Specific Ratio 

The zoom to a specific ratio feature allows you to choose the zooming ratio from the main menu. To perform zoom to a 
specific ratio, perform one of the following actions: 

·  Select Format > Zoom > Zoom Selection on the main menu, select a zoom ratio from the menu. 

 

Figure 2.58 - Select zoom ratio 

·  Right-click on the target diagram and choose Open Specification from the popup menu. This displays the Diagram 
Specification dialog box. From the dialog box, select a zoom ratio from the Zoom ratio drop down menu, or enter the 
specific zoom ratio to the field. 

·  From the property table, select a zoom ratio from the drop down menu on the row Zoom ratio, or enter the specific 
zoom ratio to the field. 
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Zooming to Fit Diagram to Window 

Beside standard zoom in/out and zoom to ratio, there are dynamic zoom options that allow you to zoom the diagram to fit its 
content to the window. 
Select Format > Zoom > Zoom Selection on the main menu (or click on the Zoom ratio combo box in the Property pane 
when a diagram is active), you will see the Page, Width  and Height zoom items. 

·  Page - Zoom the whole diagram to fit to window 
·  Width  - Zoom the width of the diagram to fit to window 
·  Height - Zoom the height of the diagram to fit to window 

 

Figure 2.59 - Select zoom ratio to fit with page 

Just select the zoom item to apply the corresponding zoom option. 
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Figure 2.60 - Zoom to show all the Page 

Zooming to Region 

The zoom to region feature allows you to zoom the diagram to any selected region. 

1. To zoom a diagram to region, click on the Zoom to Region button on the toolbar. 

 

Figure 2.61 - Zoom to region 
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2. Press the mouse on the diagram, hold and drag the desired zoom region (just like multi-select shapes). The region is 
indicated by the dotted-line rectangle. 

 

Figure 2.62 - Select the zoom region in the diagram 

3. Release the mouse button and you will see the diagram is zoomed to the desired region.  

 

Figure 2.63 - Zoom to the Region 
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Quick Previewer 

SDE for Eclipse provides a quick previewer in Diagram Navigator tree. You can preview the diagram before open the diagram. 

 

Figure 2.64 - Quick Previewer 

To preview a diagram, move the mouse cursor over a Diagram node on Diagram Navigator. This displays the Quick Previewer. 
To open the diagram, click the button on the toolbar. 
To resize the Quick Previewer window: 

1. Move the cursor to the bottom right-hand corner of the Quick Previewer window. The cursor changes to "" , 
indicating that you can resize the window. 

2. Press on it.  
3. Drag to resize the window.  
4. Releases the mouse press until you are satisfied with the size of Quick Previewer.  

Apart from preview image, Quick Previewer also shows the documentation of diagrams. To display the documentation of a 
diagram, Click the button on the toolbar of the previewer and choose Documentation. 

 

Figure 2.65 - Preview documentation 

SDE for Eclipse records the size and position of the previewer and restores this when displaying again. To reset this record, 
double-click the toolbar of the previewer window. 
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Generic Connector  

A generic connector allows you to connect any shapes, so it can represent the idea beyond the standard UML notation.You can 
edit the connector using resource. 

To edit an arrow head of a connector using Format Arrow Head resource: 

1. Click on the Format Arrow Head resource. The Format Arrow Head resource which is nearer to one end of line controls 
the arrow head at that end. 

 
Figure 2.66 - Resources for Format Arrow Head 

 

2. Select a format of arrow head in the popup menu. 

 
Figure 2.67 - Edit arrow head of generic connector 

 



SDE User’s Guide (Part 1)  Chapter 2 – Working with Diagrams 

 

2-38 

To edit the line style of a connector using the Format Line resource: 

1. Click on the Format Line resource (located in the middle of the connector). 

 
Figure 2.68 - Resources for Format Arrow Head 

 

2. Select a style of line using the Style combo box in the Format Line dialog box. 

 
Figure 2.69 - Select format of generic connector 
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You can also apply your favorite connectors. There are two methods: 

You can right click on the connector and select Format from popup menu and select Favorite Connectors > Apply Favorite 
Connectors.... 

 

 
Figure 2.70 - Select Apply Favorite Connectors 

Alternatively, you can click on the Format Line resource and select Apply Favorite Connector.... 

 
Figure 2.71 - Select Apply Favorite Connectors 



SDE User’s Guide (Part 1)  Chapter 2 – Working with Diagrams 

 

2-40 

Then, select your favorite connector to apply it. 

 
Figure 2.72 - Save your favorite connectors 

 

Apart from apply, you can organize your favorite connectors: 

1. Right click on the connector and select Format from the popup menu. 

2. Select Favorite Connectors > Organize Favorite Connectors. 

 
Figure 2.73 - Select Organize Favorite Connectors 
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3. You can choose to Create..., Duplicate..., Edit... or Remove any connectors. 

 
Figure 2.74 - Organize Favorite Connectors 

 

Text Box 

A Text Box allows you to add free text to a diagram. 

To add text using Text Box: 

1. Click on the Text Box in the toolbar. 

2. Click on the diagram pane where you want to add text. 

3. Add text in the box provided. 

 

 
Figure 2.75 - Add a free text 
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Diagram Info Shape 

Diagram Info Shape allows you to add useful information to a diagram. 
To use Diagram Info Shape: 
1. Right-click on the blank area of the diagram and select Add Shape > Diagram Info Shape from the popup menu. 

 
Figure 2.76 - Select Diagram Info Shape from popup menu 

 
2. The diagram info shape will be added to the diagram. 

 
Figure 2.77 - Diagram info shape is added 

By default, there are 2 items provided in the diagram info shape table:  
The Name cell follows the diagram name.  
The Documentation cell follows the diagram documentation. 
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To add a new item: 
1. Right-click on the diagram info shape, select Add Item from the pop-up menu. A new row will be created. 

 
Figure 2.78 - Select Add Item 

 
2. Type in the newly added item and the information in the new row. You can add as many new items as needed. 

 
Figure 2.79 - New item added 
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The diagram info shape is added. 

 
Figure 2.80 - Diagram info shape added 

 

Rich Text Documentation 

In SDE for Eclipse, you can add rich text documentation on different models and diagrams. The styles and formats of the 
documentation can be included when you generate a document. 

Rich text documentation can also be used in: 

·  Notes 

 
Figure 2.81 - Note with rich text documentation 
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·  Textboxes 

 
Figure 2.82 - Text box with rich text documentation 

 

To add rich text documentation: 
1. Right click the diagram element and select Open Specification from popup menu. 

 
Figure 2.83 - Select Open Specification 

 

2. Specify the documentation. 

 
Figure 2.84 - Specify the documentation 
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You can then switch to the Documentation pane to preview. 

 
Figure 2.85 - Documentation pane 

 

You can also see the result in the report generated. 

 
Figure 2.86 - Documentation generated 

Inserting Image to Documentation 

You can further visualize your concept by incorporating images into documentation. 
1. Select an element in the diagram. 

 
Figure 2.87 - Select a diagram element 
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2. Place the text cursor in the Documentation pane to locate where you want to insert the image, and then click the Insert 
image... button on the documentation toolbar (if this button is hidden, click the double-arrow button to expand the toolbar).  

 
Figure 2.88 - Select Insert Image... 

 

3. Select one or more images to insert. 

 
Figure 2.89 - Choose one or more images 
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4. The image(s) will be inserted to the documentation.  

 
Figure 2.90 - Image added 

 

Using Template 

By using template, you can reuse pre-defined documentation structures to save time and effort. 

To save documentation as template: 

 1. Open the specification dialog box of a model.  

 
Figure 2.91 - Select Open Specification 

 

2. After editing the documentation, click the Save as template... button on the documentation toolbar.  

  
 Figure 2.92 - Save the template 
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3. Specify the template name and click OK to save the template. 

 
Figure 2.93 - Specify the template name 
  

To load documentation from a template: 
1. Open the specification dialog box of a model. Click the template drop-down button on the documentation toolbar to select a 
saved template.  

 
Figure 2.94 - Select a saved template 

 

2. The template content is loaded. Even if you edit the documentation of the model, the template will still remain the same. 

 
Figure 2.95 - A template is loaded 
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Compartment Visibility Control 

SDE for Eclipse provides a visibility control in class diagram. It allows you to hide or show the attributes or operation using 
the resource-centric of a class. 
To show the attributes compartment or operations compartment click the " " sign button in resource-centric. To hide the 
attributes or operation click the ""sign button in resource-centric. 
You can also use popup menu to change visibility. 

 

 

Figure 2.96 - Compartment Visibility Control 

 

When you reverse the code into class diagram(s) the attributes and operations are visible by default. The 
compartment visibility control is useful when you want to hide the attributes or operations in one click 
(saves time from choosing the presentation option in the popup menu).  
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Printing Diagrams 

 

Print Preview 

The Print Preview dialog box allows you to preview the printout and provides a set of options for changing the printout style. 
To display the dialog box, perform one of the following actions: 

·  Select File > Print SDE-EC Diagrams... from main menu  

·  Click on the Print  button on the toolbar  

 

Figure 2.97 - Print preview dialog 

The toolbar of the print preview pane allows you to configure the print settings. The buttons and their descriptions are shown in 
the table below: 

Icon  Button  Function  

 Print  Print the diagram(s). The Print dialog box will be opened. 

 Quick Print  
Print diagrams without previewing them. The Quick Print dialog will be 
opened. 

 Page Setup  Set up the page properties such as paper size and orientation. 

 Adjust Margins  Adjust the margins of the pages. 

 Use Gradient Color  
Select to use gradient color in printout. Since printing gradient color will 
use up lots of memory, it is recommended to turn this option off for better 
performance. 

 
Zoom  Select the percentage to reduce/enlarge the print preview of diagrams. 

/  
Paper Base 
Layout/Diagram 
Base Layout 

If the Fit to Pages option is selected, and there are multiple pages in the 
printout, selecting Paper Base Layout will cause the distribution of pages 
to be paper-oriented (the diagram size is ignored in arranging the preview); 
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while selecting Diagram Base Layout will cause the distribution of pages 
to be diagram-oriented. Note that this option affects the preview only; the 
order of the printout remains unchanged. 

/  Paper Place Style  

To change the order of the printout. A large diagram is divided into many 
pages, selecting From left to right  will arrange the printout order from the 
pages on the left to the pages on the right, while selecting From top to 
bottom will arrange the print order from the pages on the top to the pages 
on the bottom.  

 
Fit to Ratio  Set the diagram size to fit to the specified ratio. 

 
Fit to Pages  Set the diagram to be printed on the number of pages specified. 

 
Overlapping  Set the percentage of the margins to overlap among adjacent pages. 

 
Show/Hide Clip 
Marks on Page  

Select/deselect to show/hide the clip marks on the printout. 

 Edit Header/Footer  Edit the header and the footer of the printout. 

 Multiple Page Mode Switch to the Multiple Page Mode to set the multiple page options. 

 Help  Calling the SDE-EC help file  

 Close Print Preview  Close the print preview pane and return to the design area. 

Table 2.1 
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Printing a Diagram with Preview 

You can use the Print command to select the printer. Set the range of pages and number of copies to be printed. 

1. Select the desired diagrams for printing. The selected diagrams will be shown at the preview area.  

 

Figure 2.98 - Diagram Preview 
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2. Click on the Print  button  on the Print Preview Toolbar. The Print  dialog box appears.  

 

Figure 2.99 - Print the Diagram 

3. Select the printer to use, the page range and the number of copies to be printed. You may click on the 
Properties...button to configure the printer-specific properties as well.  

4. Click OK to start printing.  
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Page Setup 
Page Setup allows the user to specify the page size, orientation as well as the margins of the pages. 

 

Figure 2.100 - Page setup 

1. Click on the Page Setup button  on the toolbar. The Page Setup dialog box appears.  
2. You can click on the Size drop-down menu to select the paper size to use.  
3. You can select the orientation for the page(s) to be printed (either Portrait  or Landscape) in the Orientation field.  
4. You can enter the value into the Left , Right, Top and Bottom text fields to adjust the size of the corresponding 

margin.  
5. Click OK to confirm the settings.  
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Adjusting Margins 
The Margins pane allows user to specify the margins of the pages, header and footer. 

 

Figure 2.101 - Adjusting Margins 

1. Click on the Adjust Margins  button  on the Toolbar. The preview area shows the margin setting page.  
2. You can edit the margins sizes by entering the sizes into the text fields. Alternatively, click on the spinner buttons to 

increase/decrease the margin sizes.  

3. Click the Finish Adjust Margin  button  when you have finished configuring the margin settings. The margin sizes 
will then be updated.  
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Zooming Pages 
Diagrams can be zoomed in or zoomed out according to user preference. 
Click on the Zoom drop-down menu to select the desired zoom ratio. 

 

Figure 2.102- Set the Zoom ratio 

The preview area will show the diagrams in the zoom ratio that you have selected. 

 

Figure 2.103 - Preview in the preview dialog 
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Selecting the Preview Layout 
There are two layouts that you can select for the print preview, the Paper Base Layout and the Diagram Base Layout. 
If the Fit to Pages option is selected and there are multiple pages in the printout, selecting Paper Base Layout will cause the 
distribution of pages to be paper-oriented (the diagram size is ignored in arranging the preview); while selecting Diagram Base 
Layout will cause the distribution of pages to be diagram-oriented. 
Note that this option affects the preview only; the order of the printout remains unchanged 

To select a layout of the preview, click on the Paper Base Layout button  or Diagram Base Layout button  on the 
toolbar.  A popup menu will appear where you can select the layout to use. 
The preview after applying the Paper Base Layout: 

 

Figure 2.104 - Preview in paper Base Layout 
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The preview after applying the Diagram Base Layout: 

 

Figure 2.105 - Preview in Diagram Base Layout 
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Setting Paper Place Style 
You can select the paper place style to change the order of the printout. To select the paper place style, click on the Paper 
Place Style button on the toolbar. A popup menu appears where you can select a paper place style. 
Consider a large diagram is divided into many pages, selecting 'From left to right ' will arrange the printout order from the 
pages on the left to the pages on the right, while selecting 'From top to bottom' will arrange the print order from the pages on 
the top to the pages on the bottom 
The order of the printout after selecting From left to right . 

 

Figure 2.106 - Printout order is left to right 
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Fit to Ratio  
Fit to Ratio is used to resize the diagrams in the printout to a specific ratio. 
Click on the Fit to drop-down menu and select Ratio. 
You can enter the ratio into the textbox, e.g. enter 150 to set the ratio to 150%. After you have edited the ratio, the diagrams in 
the printout will be resized to the new ratio. 

 

Figure 2.107 - Fit to ratio 

Fit to Pages 
Fit to Pages is used to split the diagram to a desired number of pages when printing. 

1. Click on the Fit  to drop-down menu and select Pages.  

2. Click on the Multiple Pages button  on the toolbar. The page selector appears.  

 

Figure 2.108 - Select multiple pages Page 

3.  
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4. Click on the row-column combination to select it (note that you can click and drag on the page selector to extend the 
selection). The diagram will be split into multiple pages by the rows and columns that you have selected.  

Figure 2.109 - Fit to page 

Setting the Diagram Overlap Percentage 
Overlapping is used when users want the diagrams to have overlapping at the boundaries between pages. This is particularly 
useful when you have a large diagram that span multiple pages and you want to stick the pages of the printout together; the 
overlapping area can then be used as a hint when sticking the pages. 

 

Figure 2.110- Multiple page without overlap 

1. Click on the Overlapping textbox to input the overlapping percentage and press the Enter key.  
2. The printing area near the boundaries of the pages will be duplicated by the overlapping percentage inputted.  



SDE User’s Guide (Part 1)  Chapter 2 – Working with Diagrams 

 

2-63 

 

Figure 2.111 - Multiple page with overlap 

 

Printing with Frame/Border Option 
You can print your diagram with a frame or border. There are three options: 

·  With frame 
·  With border 
·  No border 

Select With frame/ With border/No border option from the drop-down menu. 

 
Figure 2.112 - Select option from drop-down menu 
 
Output of printing with frame 

 
Figure 2.113 - Printing with frame 
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Output of printing with border 

 
Figure 2.114 - Printing with border 

 
Output of printing with no border 

 
Figure 2.115 - Printing with no border 
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Showing/Hiding Clip Marks on Page 
Clip marks act as an indication of the boundary of a page. 

 

Figure 2.116 - Clip marks 

To show clip marks on the printout click on the Show Clip Marks on Page button . You will see the boundaries of the 

pages are surrounded by clip marks. To hide the clip marks click on the Hide Clip Marks on Page button  again. 

Editing Header/Footer of the Pages 

To edit the header/footer of the printout click on the Edit Header/Footer button  on the toolbar. You will then switch to the 
edit header/footer pane. 

 

Figure 2.117 - Editing Header/Footer of the Pages 

You can edit the header and the footer in the Header panel and the Footer panel respectively. Each of the panel consists of the 
Left Section, Center Section and the Right Section, which represents the position that the content will be located in the 
header/footer. 
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There is a toolbar between the Header panel and the Footer panel, which facilitates the editing of header/footer. The 
description of the buttons in the toolbar can be found in the following table: 

Icon Name  Description  

 Select Font  
Select the font to use for the selected section. Note that you must click on the section once in order 
to select it  

 Insert Page Number  Insert the page number 

 
Insert Number of 
Page  

Insert the total number of pages  

 Insert Date  Insert the date that the printing starts  

 Insert Time  Insert the time that the printing starts  

 Insert File Name  Insert the file name of the SDE-EC project  

 Insert Project Name  Insert the name of the SDE-EC project  

 Insert Diagram Name Insert the diagram name  

Table 2.2 

After you have finished editing the header/footer, click on the Close Edit Header/Footer button  to switch to the print 
preview mode. A sample page that has the header and footer formatted is shown in the picture below: 

 

Figure 2.118 - Page with header and footer 
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The Multiple Page Mode 
The Multiple Page Mode allows users to configure how the diagrams should be distributed in multiple pages. To switch to the 

Multiple Page Mode click on the Multiple Page Mode button  on the toolbar. 
Clicking on the button beside the Multiple Pages field will invoke the page selector, where you can select the row-column 
combination for the printout. Alternatively, you can type in the Row and Column text field directly. 

 

Figure 2.119 - Select multiple page 
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Click on the button beside the Page Style field to change the printout order. Consider a large diagram is divided into many 
pages, selecting 'From left to right'  will arrange the printout order from the pages on the left to the pages on the right, while 
selecting 'From top to bottom'  will arrange the print order from the pages on the top to the pages on the bottom. 

 

Figure 2.120 - Distributes diagram in multiple page 

After you have finished configuring the multiple page settings click on the Close Multiple Page Mode button to close the 
Multiple Page Mode. 
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Printing a Diagram with Quick Print  

The Quick Print feature allows you to print diagrams without previewing them, hence speeding up the print job. To quick print, 
perform one of the following actions: 

·  Select File > Print SDE-EC Diagrams... from main menu. This displays the Print Preview dialog box. Click  on 
the toolbar of the Print Preview dialog box.  

In both cases, the Quick Print  dialog box will show.  

 

Figure 2.121- Quick Print dialog 

Field  Description  

Print Range  

Click on either of the below options to specify the print range. 
All - Print all the diagrams within the current project 
Active - Print only the active diagram 
Diagrams - Check from the diagram tree to select the diagram(s) for printing 

Scaling  
Select No scaling to print with diagrams' original size. Numbers of pages used for each diagram are subject to the 
scale of diagrams. Select Fit to pages to print with specified number of pages per diagram with respect to the 
specified number of rows and columns. 

Border 
option 

Select border option of printout. 

Page 
Setup...  

Page Setup allows you to specify the page size, the orientation as well as the margins of the pages.  

Page 
numbers  

Select to print diagrams with page number on it. 

Use 
gradient 
color 

Select to use gradient color in printout.  

Table 2.3 
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Shape Alignment 

Aligning Shapes 

This feature provides a facility to align selected diagram elements. You can align using toolbar, popup menu or group resource.  
All alignment methods calculate the resulting shape boundaries on a referenced shape. You can refer to the section 'Referenced 
Shape for Alignment' for details. 
Before you use any one of  the methods to align, you should first select more than one shape.  

 

 
Figure 2.122 - Three use cases selected 

Here, three use cases aligning towards the top is used as an example. 
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To align using toolbar, you can select Format > Alignment > Top from the main menu. 

 
Figure 2.123 - Select Top from main menu 
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To align using popup menu, you can select Alignment > Top in the popup menu. 

 
Figure 2.124 - Select Top from popup menu 

 

To align using group resource, you can select the Alignment resource > Align Top which appears when two or more shapes 
are selected. 
You can select the way of aligning from the drop-down menu. 

  

 
Figure 2.125 - Select Align Top from Alignment resource 

 

By using any of the above methods, the shapes are aligned. 

 
Figure 2.126 - Shape aligned 
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Distributing Shapes 

This feature provides a facility to distribute selected diagram elements with uniform space. You can use resource, toolbar and 
menu to distribute shapes. 
Before you use any one of the methods to distribute shapes, you should first select more than two shapes.  

 
 Figure 2.127 - Three use cases selected 

 Here, three use cases distributing horizontally is used as an example. 
 
Use resource to distribute shapes: 
To align using group resource, you can select the Distribute resource > Distribute Horizontally  which appear when more 
than two shapes are selected. 

 
 Figure 2.128 - Select Distribute Horizontally 

 

The use cases after Distribute Horizontally . 

 
 Figure 2.129 - Three use cases distribute horizontally 
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Making Shapes Same Width and Height 

This feature provides a facility to set selected diagram elements to the same width, same height, or both. You can use resource, 
toolbar and menu to make the shapes being the same width/height. 
The methods calculate the resulting shape boundaries based on a referenced shape. You may refer to the section 'Referenced 
Shape for Alignment section' below for details. 

  

You need to select two or more shapes in order to apply this feature. Here, making three use cases the same width is used as an 
example. 

 
 Figure 2.130 - Three use cases selected 

 
To make shapes same width, you can select Make Same Width resource > Same Width. 

 
 Figure 2.131 - Select Same Width 

 
The resultant use cases now have the same width. 

 
Figure 2.132 - Resultant use cases 
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Referenced Shape for Alignment 

When there are multiple shapes selected, the last selected shape will be used as the referenced shape for alignment. That is, the 
alignment method will be performed based on the position/size of the referenced shape. The referenced shape will be rendered 
with its resize handles surrounded by white rectangles. 

 

Figure 2.133- before and after Alignment left 

You can set a shape as the referenced shape for alignment (if it is currently not) by shift-clicking on the shape for two times 
(the first time to deselect the shape, and the second time to reselect it). 
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Using the Align Shapes Dialog Box 

You can invoke the Align Shapes Dialog either Format > Alignment > Align shapes... in the menu bar or the toolbar, or 
using the hot key F12. The Align Shapes dialog box allows you to configure the top/bottom, left/right alignments and same 
width/same height options all at a time. Select the desired options and click OK to apply the settings. 

 

Figure 2.134 - Align Shapes Dialog 

Visual Alignment Guide 

When you move a shape, visual alignment guide helps you to align with the closest shape. The guide lines show the vertical 
edge of the closest shape if you move a shape horizontally. Similarly, the guide lines show the horizontal edge if you move a 
shape vertically. 
Here, a use case moving horizontally to align with other use cases is used as an example. 
 
To align with other shapes: 
1. Move the use case which you want to align with others. You can see the Visual Alignment Guide line. 

  

 
Figure 2.135 - Use case with guide lines before alignment  
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2. Move until the use case align with the others. 

 
Figure 2.136 - Move the use case 

 
3. Release the mouse and you will see the aligned use case. 

 
Figure 2.137 - Use case aligned 
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You may also change the alignment guide style, or enable/disable it. 
1. To perform these task, select Modeling > Application Options... to open the Options dialog box.  

Figure 2.138- Options dialog box 

 
2. Select Diagramming > Environment tag. 

 
Figure 2.139 - Select Environment tag 
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To enable/disable the guide lines, check/uncheck the option Show diagram alignment guide. 

 
Figure 2.140 - Enable/disable the guide lines 

 
You can also change the guide line style by choosing Show edges or Show center. 
   

 
Figure 2.141- Change the style of guide lines 

 
If you choose Show center, the guide line shows the center of the closest shape. 

 
Figure 2.142 - Show center of the closest shape 

 
If you choose Show edges, the guide lines show the edge of the closest shape. 

 
Figure 2.143 - Show edges of the closest shape 
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Selectable 

The option allows you to make certain diagram elements read-only so that you can focus on editing other elements.  All 
diagram elements are selectable by default. 

To make one or more diagram elements non-selectable: 

1. Right-click on the elements and deselect from the popup menu to make the selected element non-selectable. 

 
Figure 2.144 - Deselect the selectable option 
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2. When a diagram element is non-selectable, it can not be detected by mouse or key actions.  This means that if you click or 
drag on it, it will be the same as clicking or dragging on the white space of the diagram and nothing with happen 

 

 
Figure 2.145 - Diagram element after deselection 
. 

3. To make a non-selectable diagram element selectable again, right-click on it and select Selectable from the popup menu. 

 
Figure 2.146 - Diagram element can be selected again 
 

4. You may also right-click on the diagram and select Make All Non-Selectable/Make All Selectable from the popup menu to 
make all elements non-selectable/selectable. 

 
Figure 2.147 - Make all diagram elements Selectable or Non-selectable 
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Locking a Diagram 

If a diagram is locked, you can only view but not change the elements on the diagram. 
A diagram is locked by right-clicking the diagram and then selecting Lock Diagram from the popup menu. 

 
Figure 2.148- Locking a diagram 
 


